Tools en downloads voor ontwikkelaars

Op deze pagina vind je tools en documentatie voor het ontwikkelen van software die mapcodes gebruikt. Dat is handig als je meer wilt weten over de achtergrond en details van hoe mapcodes zijn gedefinieerd. Onze ontwikkelaar sectie omvat:

Maven dependency

Om de Mapcode Java Library in je Maven project te gebruiken, voeg je de volgende dependency toe aan je Maven pom.xml file:

<dependency>
  <groupId>com.mapcode</groupId>
  <artifactId>mapcode</artifactId>
  <version>2.4.12</version>
</dependency>

Source code, voorbeeld code en documentatie kun je vinden op onze Java source code pagina.

Converteren van locatie naar mapcode and v.v.

We leveren een cross-platform console tool, genaamd mapcode. Die bevindt zich in de  utility directory van onze C/C++ Mapcode library. Je vindt dat hier:

Je moet zelf de tool compileren op het OS of platform naar keuze.

Een spreadsheet gebruiken voor mapcodes

In plaats van de console tool om mapcodes te converteren, kun je ook een Excel (Windows) of Google Docs spreadsheet gebruiken, om met behulp van onze gratis web service mapcodes te converteren.

Om een mapcode naar een locatie te converteren, kun je in Excel bijvoorbeeld deze formule gebruiken:

=WEBSERVICE("http://api.mapcode.com/mapcode/xml/coords/Q4.HGY?context=NLD")

Dit converteert de mapcode Q4.HGY naar locatie 52.460897, 5.1074585. Omgekeerd, om een locatie terug te converteren naar een mapcode:

=WEBSERVICE("http://api.mapcode.com/mapcode/xml/codes/52.460897,5.1074585")

Hier vind je een voorbeeld spreadsheet in Excel (Windows):

Google Docs kan min of meer hetzelfde doen. Om te zien hoe dat werkt, klik hier.

Oudere tools

We bieden ook wat oudere Windows tools, hoewel deze op gegeven moment niet meer ondersteund kunnen worden. De console tool mapcoder.exe kan bijvoorbeeld heel snel coordinaten omzetten in mapcodes en vice versa, voor een heel spreadsheet of database. Volledige documentatie van de tool is inbegrepen.

De oudere versie van deze tool is ook nog beschikbaar (version 1.50.1). Deze is nodig om pre-2.0 codes te gebruiken. Het gebruik van pre-2.0 codes wordt afgeraden, maar we bieden deze tool nog voor het geval je er (nog) niet onderuit komt.

Copyright © 2019, Stichting Mapcode Foundation

  • c-facebook